Identified - Email Delivery - Delayed sending

Incident Report for Signable Status Page

Update

Microsoft has acknowledged the incident, and services are beginning to recover https://x.com/MSFT365Status - please reach out to Microsoft directly for more updates.
Posted Sep 04, 2026 - 16:18 BST

Monitoring

We have identified the problem as an issue with the downstream Microsoft-supported services. We will provide another update as soon as more information becomes available.
Posted Sep 04, 2026 - 14:06 BST

Identified

We have identified a downstream issue affecting email sending, causing delayed email delivery. We're monitoring the issue.
Posted Sep 04, 2026 - 11:01 BST
This incident affects: Email.